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This handout has been written by students with no intention to substitute the University official materials. Its 
purpose is to be an instrument useful to the exam preparation, but it does not give a total knowledge about the 

program of the course it is related to, as the materials of the university website or professors. 
 

EXCEL FORMULAS AND MAIN 

FUNCTIONS 
 

FORMULAS AND COMMANDS 
 

•    ABS function (number) 

• 	 	Data import from the Web and from text files right key, copy and paste  

• 	 	Paste command options (Values) 

• 	 	Sort and filter 

• 	 	Conditional formatting (with or without formulas) 

• 	 	TRIM (text) delete all empty spaces  

• 	 	COUNT (value 1, value 2...)  Counts the number of cells in a range that contains numbers  

• 	 	COUNTA (value 1, value 2...)  Count the number of non-blank cells in a range  

• 	 	COUNTBLANK (range) count the number of blank cells in a range  

• 	 	SUM (number 1, number 2...)  Calculates the sum of a group of values 

• 	 	AVERAGE (value 1, value 2...)  Calculates the mean of a group of values  

• 	 	ROUND (text, n of decimal places) Rounds a number to a specified number of decimal places  

• 	 	INT (text) Removes the decimal portion of a number  

• 	 	PRODUCT (number 1, number 2...)  Multiplies the cells in the range 

• 	 	MIN (range of values) Calculates the smallest number in a range  

• 	 	MAX (range of values) Calculates the smallest number in a range  

• 	 	IF (logical-test, value-if-true, value-if-false) tests for a true or false condition  

• 	 	AND (logical 1, logical 2) Returns TRUE if all its arguments are TRUE  

• 	 	OR (logical 1, logical 2...) Returns TRUE if any argument is TRUE 

• 	 	SUMPRODUCT (array 1, array 2...) 

• 	 	Subtotal Data -> Subtotal. Use the dialog box to define which column you want to subtotal and 

the calculation you want to use 

• 	 	Remove duplicates Data -> Remove Duplicates button. Select which columns you want to check 

for duplicates 

• 	 	COUNTIF (range,criteria) 

• 	 	SUMIF (range, criteria, sum-range) a sum from a group of values in which a condition has been 

met`  

• 	 	AVERAGEIF (range, criteria, average range) 

• 	 	Charts with a trendline, mixed and with two axes 

• 	 	PMT (rate, nper, pv, fv, type) Calculates the total payment on a debt security, loan rate, number of 

periods, future and present value  

• 	 	FV Calculates the future value of an investment 
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• 	 	Naming cells and ranges 

• 	 	Paste command options (Transpose) 

• 	 	what-if analysis 

• 	 	Scenarios 

• 	 	Goal seek Data -> What-If Analysis -> Goal Seek. Specify the desired value and which cell can be 

changed to reach the desired result.  

• 	 	RIGHT (text, number of characters) Extracts one or more characters from the right side of a text 

string  

• 	 	LEFT Extracts one or more characters from the left side of a text string  

• 	 	MID (text, start-number, number-of-characters) Extracts characters from the middle of a text string  

• 	 	CONCATENATE (text 1, text 2...)  Merges two or more text strings  

• 	 	REPLACE Replaces part of a text string  

• 	 	TEXT Formats a number and converts it to text  

• 	 	VALUE Converts a text cell to a number 

• 	 	UPPER (text) Converts a text string to all uppercase  

• 	 	LOWER (text) Converts a text string to all lowercase 

• 	 	PROPER (text) Converts a text string to proper case  

• 	 	LEN (text) Returns a text string’s length in characters  

• 	 	SEARCH (find-text, within-text, start-number) 

• 	 	COUNTIFS (criteria range 1, criteria 1...) 

• 	 	SUMIFS (sum-range, criteria-range1, criteria1...) 

• 	 	AVERAGEIFS (average range, criteria, range1, criteria1...) 

• 	 	Pivot tables and pivot charts 

• 	 	Data validation Select the cells -> Data -> Data Validation->Allow and select the data you want to 

allow 

• 	 	DAY (cell) 

• 	 	MONTH (cell) 

• 	 	YEAR (cell)   

• 	 	HOUR (cell) 

• 	 	MINUTE (cell) 

• 	 	SECOND (cell) 

• 	 	WEEKDAY (cell, return-type [we must put 1, i.e. American type]) 

• 	 	TODAY() Show the current date without the time  ex. Today()+10 add ten days to the current date 

• 	 	NOW (cell) Show the date and time  

• 	 	DATE (yyyy,mm,dd) (or y,m,d) 

• 	 	DATEDIF (date 1, date 2, “y” or “m” or “d”) 

• 	 	IFERROR (value, value if error) 

• 	 	VLOOKUP (lookup-value, table-array, column-index, range-lookup)->TRUE=approximate match, .         

FALSE=exact match 

• 	 	HLOOKUP: Looks for and retrieves data from a specific row in a table.  

• 	 	MATCH (lookup-value, lookup-array, match-type) =>0=exact match, 1= largest value that is <=to .    

lookup-value,-1= smallest value that is >= to lookup-value=> Locates position of a lookup value in a 

row or column 

• 	 	RANK.EQ (number, reference, order), 0=descending, 1=ascending 
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• 	 	INDEX: Returns a value or the reference to a value from within a range.  

• 	 	Worksheet, workbook and file protection	 

• 	 	Macros view => record macro 

 

 

 

SHORTCUTS 
 

 

Open a workbook................ Ctrl + O  

 

Create a new workbook ....... Ctrl + N  

Print a workbook ................. Ctrl + P  

Move between cells ............. ­, ¯, ¬, → 

Right one cell ...................... Tab 

Left one cell ........................ Shift + Tab  

Down one cell ..................... Enter  

Up one cell.......................... Shift + Enter  

Down one screen ................ Page Down  

To cell A1............................ Ctrl + Home  

To last cell........................... Ctrl + End  

Cut ..................................... Ctrl + X 

Copy................................... Ctrl + C  

Save a workbook................. Ctrl + S  

Paste .................................. Ctrl + V  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Undo .................................. Ctrl + Z  

Redo................................... Ctrl + Y  

Find .................................... Ctrl + F  

Replace .............................. Ctrl + H  

Bold.................................... Ctrl + B  

Italics .................................. Ctrl + I  

Underline ............................ Ctrl + U  

Select All............................. Ctrl + A  

Select entire row ................. Shift + Space  

Select entire column ............ Ctrl + Space  

Hide selected rows .............. Ctrl + 9 

Hide selected columns......... Ctrl + 0  



 

MAIN FUNCTIONS 

GENERAL  

Select a Cell Range: Click and drag to select a range of cells. Or, press and hold down the Shift key 
while using the arrow keys to move the selection to the last cell of the range.  

Select Non-Adjacent Cells: Click the first cell or cell range, hold down the Ctrl key, and select any non-
adjacent cell or cell range.  

Wrap Text in a Cell: Select the cell(s) -> Home -> Wrap Text  

Merge Cells: Select the cells ->Home -> Merge & Center  

Absolute References: add dollar signs ($) to the reference you want to remain absolute  

Name a Cell or Range: Select the cell(s), ->Formula bar -> Name box, type a name for the cell or range, 
and press Enter.  

Reference Other Worksheets: To reference another worksheet in a formula, add ‘!’ after the sheet 
name in the formula 

Display Worksheet Formulas: Click the Formulas  -> formula auditing -> Show Formulas  

Export Data: Click File, Export, Change File Type. Select the file type you want to export the data to 
and click Save As.  

Import Data: Data -> Get Data. Select the category and data type, and the file you want to import. Click 
Import, verify the preview, and then click the Load button.  

Outline and Subtotal: Data -> Subtotal, define which column you want to subtotal and the calculation 
you want to use.  

Format a Cell Range as a Table: Select the cells -> home -> styles group -> Format as Table and select 
a table format from the gallery.  

Sort Data: Select a cell in the column you want to sort -> home -> Sort & Filter -> sort order or select 
Custom Sort  

Filter Data: Click the filter arrow for the column you want to filter. Uncheck the boxes for any data you 
want to hide.  

Add Table Rows or Columns: Select a cell in the row or column next to where you want to add blank 
cells -> Insert button list arrow on the Home tab. Select either Insert Table Rows Above or Insert Table 
Columns to the Left.  

Table Style Options: Click any cell in the table -> Design -> Table Style Options group.  

Apply Cell Styles: Select the cell(s) -> Home -> Cell Styles and select a style or Cell Style to define a 
custom style.  

Apply a Workbook Theme: Page Layout -> Themes  



 

 

Add a Cell Comment: Click the cell where -> Review tab -> New Comment button.  

Invite People to Collaborate: Share -> Enter the email addresses -> select a permission level, Apply. 
Type a message and click Send.  

Protect a Worksheet: Before protecting a worksheet, you need to unlock any cells you want to remain 
editable after the protection is applied. Review -> Protect Sheet. Select what you want to remain 
editable after the sheet is protected.  

Add a Workbook Password: File -> Save As -> Browse to select a save location -> Tools -> General 
Options. Set a password  

 

PIVOT TABLE  

Group PivotTable Values: Select a cell in the PivotTable that contains a value you want to group by. -> 
Analyze ->Group Field. Specify how the PivotTable should be grouped  

Refresh a PivotTable: With the PivotTable selected, -> Analyze -> data group ->Refresh  

Format a PivotTable: With the PivotTable selected ->Design -> pivot table options and styles ->select 
formatting options  

Create a PivotChart: Click any cell in a PivotTable -> Analyze ->tools -> PivotChart-> Select a 
PivotChart type  

Modify PivotChart Data: Drag fields into and out of the field areas in the task pane.  

Modify PivotChart Elements: PivotChart selected-> Design -> chart elements ->Add Chart Element 
and select the item(s) you want to add to the chart.  

Apply a PivotChart Style: Select the PivotChart -> Design -> chart styles -> Select a style from the 
gallery.  

Update Chart Type: With the PivotChart selected -> Design -> type -> Change Chart Type Select a 
new chart type  

Enable PivotChart Drill Down: Analyze ->Field Buttons list arrow in the Show/Hide group ->Show 
Expand/Collapse Entire Field Buttons.  

Subtotals: Show or hide subtotals and specify their location in the PivotTable.  

Grand Totals: Add or remove grand total rows for columns and/or rows.  
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MACRO 

Enable the Developer Tab: File -> Options-> Customize Ribbon at the left. Check the Developer check 
box  

Record a Macro: Developer -> Record Macro. Type a name and description then specify where to save 
it. Complete the steps to be recorded. Click the Stop Recording button on the Developer tab.  

Run a Macro: Developer -> Macros -> Select the macro and click Run.  

Edit a Macro: Developer -> Macros -> Select a macro -> Edit. Make the necessary changes to the Visual 
Basic code -> Save  

Delete a Macro: Developer -> Macros -> Select a macro -> Delete  

Macro Security:  Developer -> Macro Security button. Select a security level  

 

ERRORS  

• ####### - The column isn’t wide enough to display all cell data.  
• #NAME? - The text in the formula isn’t recognized.  
• #VALUE! - There is an error with one or more formula arguments.  
• #DIV/0 - The formula is trying to divide a value by 0.  
• #REF! - The formula references a cell that no longer exists.  

Error Checking: Select a cell containing an error ->Formulas -> formula auditing->Error Checking  

 

CONDITIONAL FORMATTING  

Apply Conditional Formatting: Select the cells -> Home tab -> Conditional Formatting. Select a 
conditional formatting category and rule  

Customize Conditional Formatting: home -> Conditional Formatting -> New Rule. Select a rule type, 
then edit the styles and values.  

Edit a Conditional Formatting Rule: home->Conditional Formatting -> Manage Rules ->Select the rule 
-> Edit Rule.  

 
  

http://bit.ly/Peer2Peer_Bocconi 

http://bit.ly/Blab_Bocconi 

https://www.blabbocconi.it/dispense/ 

 @blabbocconi 



 

 

 


